Cavalcante Consultores – treinamento e consultoria em finanças e Excel

Deslocamento (DESLOC)

Cavalcante Consultores > Biblioteca de Excel > Deslocamento (DESLOC)

O que é?

A função DESLOC é uma função extremamente versátil, através dela podemos reduzir ou expandir uma matriz de uma fórmula. Quando dizemos matriz estamos falando de intervalos de células.

Como aplicar a função

Veja a sintaxe abaixo:

=DESLOC(referência; linhas; colunas; altura; largura)

Onde:

Usaremos como exemplo a planilha abaixo:

Onde utilizaremos a função DESLOC para que a soma a ser exibida na célula D13 seja automaticamente atualizada quando da inserção de novos valores a tabela que compreende o intervalo de células B1:B12. Siga os passos abaixo:

=SOMA(DESLOC(B1;0;0;12;1))

Veja na figura abaixo:

Neste caso usamos como referência a célula B1, que esta localizada na mesma coluna de onde deslocaremos os dados.

Seguidos os passos o resultado obtido será o da figura abaixo:

Exemplo

Veja que o resultado é o mesmo da função SOMA, mas agora podemos inserir novos valores na tabela e estes serão atualizados(somados) automaticamente na célula de destino, conforme figura abaixo:

Pratique!