Cavalcante Consultores – treinamento e consultoria em finanças e Excel

Texto

Cavalcante Consultores > Biblioteca de Excel > Texto

O que é?

É uma função usada para exibir o conteúdo de uma célula, com um formato definido pelo usuário, em outra célula.

Como aplicar a função texto

Veja a sintaxe abaixo:

=TEXTO(valor; format_texto)

Onde valor é o conteúdo da célula, seja ele um valor numérico, texto ou fórmula, e format_texto é o formato no qual queremos que o conteúdo da célula seja exibido.

Exemplo

Usaremos como exemplo a tabela abaixo:

Onde utilizaremos a função TEXTO para definir o formato de texto que será exibido nas duas células de destino, sigamos os passos:

=TEXTO(E3;"R$ 0.000,00")

Isto nos deixará como na figura abaixo:

Repare que o conteúdo da célula de origem esta sem formato e quando utilizamos a função TEXTO o conteúdo toma o formato que definimos na função.

Obs: As aspas (""), são utilizadas neste caso para definir que queremos que o formato a ser exibido seja em forma de texto. Mas se a célula de origem contiver apenas texto, podemos substituir as aspas pelo zero, pois assim somente será exibido o conteúdo original da célula de origem.

Seguidos os passos o resultado encontrado é o da figura abaixo:

Pratique!